Jump to content

Starter Solenoid?


wemtd
 Share

Recommended Posts

Everything I've touched this weekend has broken: this afternoon the seven's starter motor died (again). A similar failure occurred about 3-4years ago (motor spins but pinion doesn't engage flywheel).  It's the stock/standard duralast ford focus starter for my 2L duratec. I do have a Odyssey battery. 

I'v been lead to believe this is a solenoid problem, does this sound correct?

Is this just bad luck or is there something I should check/fix that could be causing this to prematurely fail?

 

thanks.

Link to comment
Share on other sites

If the starter motor spins the solenoid is working. It sounds to me like the issue is with the pinion gear engagement. Was the starter weak before it failed? I don't know how the pinion gear gets pushed towards the flywheel, but if it is purely mechanical it could simply be that it needs a good cleaning/degreasing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...