Jump to content

Wiring diag- 84 Crossflow seven


Recommended Posts

Hi gents,

Does anyone have a wiring schematic for a caterham s3 with 1600 crossflow of this period? The previous owner of my car had someone make some modifications to the harness when components were removed at some point. I realized after i purchased the car that my turn signals never worked so while i'm currently upgrading my headlights and installing LED turn signals, i figure it's a good time to sort everything out. Thanks for any help on the matter!

Cheers,

Des. 

Link to post
Share on other sites

Get the Tony Weale book "LOTUS SEVEN Restoration, Preparation, Maintenance. It has wiring diagrams. I don't know whether the diagrams in the book are copyrighted, so I cannot post them here.

Link to post
Share on other sites
  • 2 weeks later...

Hello, I am enclosing what I have used for my '85 S3, 1.6l Kent imperial chassis. Here it is. I gave up on keeping headlights several years ago. Now I work to maintain brake lights. Good luck. Help can also be found at Dave Bean in San Andreas CA. They bought the stock from Lotus when they departed the pattern several years ago. Ken Gray is the one I deal with. He is v-nice and helpful, he has an indentured servitude  relationship with the company  since he owns a Lotus Elan. 

ken@davebean.com

Good luck

wiring diagram 85 seven:kent.pdf

Link to post
Share on other sites
1 hour ago, ultraslow said:

Hello, I am enclosing what I have used for my '85 S3, 1.6l Kent imperial chassis. Here it is. I gave up on keeping headlights several years ago. Now I work to maintain brake lights. Good luck. Help can also be found at Dave Bean in San Andreas CA. They bought the stock from Lotus when they departed the pattern several years ago. Ken Gray is the one I deal with. He is v-nice and helpful, he has an indentured servitude  relationship with the company  since he owns a Lotus Elan. 

ken@davebean.com

Good luck

wiring diagram 85 seven:kent.pdf 559.2 kB · 6 downloads

 

Thanks very much. Took some time but i got everything sorted a few days ago and- had to do clean up  some of the old wiring as well. Headlamps, turn signals and brakes work now. For the record and to help someone else down the road. 

 

Turn signals- some corrosion on the connectors and some interference with hazard lights. i had to flick the hazard switch on and off a few times after checking all wires. but everything works well now. Also upgraded to LED turn signals. 

 

Brake lights- Old brake switch failed. Replaced with new brake switch- it's a lucas spb401

 

Headlamps- some faulty connectors/funky wiring. did some rewiring while changing from 7" to 5-3/4 headlamps. All works now. 

 

Cheers,

Des. 

Link to post
Share on other sites
9 hours ago, ultraslow said:

Hello, I am enclosing what I have used for my '85 S3, 1.6l Kent imperial chassis.

 

Thank you for the contribution @ultraslow    I have saved that to the forum's technical library for people to future reference. 

 

If people are looking for the technical library you can find it by going to top left of the screen and selecting "Browse" then underneath it "Downloads" then look at the categories in the menu on the right of the screen.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...